Back to overview
Degraded
Email notification & OTP issue
Apr 10, 2026 at 11:00am UTC
Affected services
Published Websites
Resolved
Apr 10, 2026 at 11:20am UTC
The issue has been resolved by our email provider
Affected services
Created
Apr 10, 2026 at 11:00am UTC
We're investigating an issue preventing sending emails from generated apps (like notifications on OTP code).
Affected services