Back to overview
Degraded

Stock photos downtime

Feb 26, 2026 at 02:00pm UTC
Affected services
AI Chat

Resolved
Feb 26, 2026 at 05:03pm UTC

Stock photos are available again.

Created
Feb 26, 2026 at 02:00pm UTC

Searching for stock photos using Pexels is currently not working, Macaly agent will usually provide an alternative solution